C1P Owner in Germany

Introduce yourself and reminisce
Post Reply
stm
Posts: 43
Joined: Mon Oct 27, 2014 10:23 pm
Location: Germany

C1P Owner in Germany

Post by stm » Mon Oct 27, 2014 10:55 pm

Hello everybody,

my name is Stephan and I live in Germany near Munich.

The C1P was my first computer. I got it back in 1980 when I was 16 years old, and with it I learned programming.

In 2013 I fetched it out of the basement, cleaned it and turned it back on. Here are a few photos on Google +:

https://plus.google.com/photos/10475176 ... 5746087009

As you can see it in one photo, I was able to attach it to my flatscreen TV.

I tried to add the RS232 interface to the board, as it is described in "The First Book of Ohio Scientific". Unfortunately I couldn't get it to work at that time and gave up, but now that I found this forum I might give it another try.

Other things I'm interested in are the JavaScript C1P simulator at pcsjs.org and the cc65 C compiler for the 6502.

Best Regards
Stephan
C1P Model 600 CPU 1978 REV B, 40K (8K original and 32K BillO memory expansion), RS-232
Maintainer of cc65 OSI target

MK14HAK
Posts: 343
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: C1P Owner in Germany

Post by MK14HAK » Sat Nov 01, 2014 3:07 am

Welcome Stephan. Great to hear from another OSI user and what a nice C1P.
We are happy to help sort the RS232 for you. What test equipment do you have ? I have a working C1P RevD with serial @ 600/2400 baud that I use with Tera Term and winOSI emulator on the PC. I will check my RevD cct against the FBOSI version. Are you using a negative supply?
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:HexDOS,FDD Emulator

stm
Posts: 43
Joined: Mon Oct 27, 2014 10:23 pm
Location: Germany

Re: C1P Owner in Germany

Post by stm » Sun Nov 02, 2014 6:58 pm

MK14HAK wrote:Welcome Stephan. Great to hear from another OSI user and what a nice C1P.
Thanks, I'm glad to hear that you like it! I always treated it very carefully...
MK14HAK wrote:We are happy to help sort the RS232 for you. What test equipment do you have ? I have a working C1P RevD with serial @ 600/2400 baud that I use with Tera Term and winOSI emulator on the PC. I will check my RevD cct against the FBOSI version. Are you using a negative supply?
I appreciate your offer, and I will come back to you once I get back to work on the hardware. So far I'm suspecting that I made I mistake in soldering, and I might have to resolder one of the resistors.

At the moment I have no test equipment except a digital multimeter and a RS232 USB adapter for my laptop to connect to. What equipment would be necessary to troubleshoot this? Maybe I can borrow some tools from friends.

I'm not using a negative power supply. I think I read that a negative power supply normally should not be necessary.
C1P Model 600 CPU 1978 REV B, 40K (8K original and 32K BillO memory expansion), RS-232
Maintainer of cc65 OSI target

Post Reply