Page 1 of 1

Just pulled out my C1P

Posted: Mon Jan 21, 2019 6:57 am
by keith
Circa 1978, I bought a C1P. Actually, I think my parents did most of the buying.

Anyway, a few days ago, I grew curious about it, and I pulled it from the shelf it has been on all these years.

To my considerable surprise, I found that I have 3 original manuals in excellent condition. Tonight I opened the case on the C1P, and it looks almost like it just came from the factory. I haven't tried turning it on yet.

It seems a pretty early unit. One of my manuals is marked "preliminary" and dated Aug 1978.

I'm not quite sure what to do with it.


Re: Just pulled out my C1P

Posted: Mon Jan 21, 2019 7:08 pm
by dave

To be safe, you may want to disconnect the power supply from the board before powering up, to confirm the supply is giving you close to 5V. If so, you should be safe powering up the board and connecting it to a composite monitor or TV. Browse the forums to see the latest developments. If you need any help, you are at the right place!

I think many of the manuals were marked "preliminary", but that's how OSI rolled :-)

Good luck,


Re: Just pulled out my C1P

Posted: Mon Jan 28, 2019 5:58 am
by keith
As you suggested (thanks), I tested the power supply voltage and found it to be 5.19V. So I fired the C1P up and I get the D/C/W/M prompt, but after that the keyboard malfunctions, in the sense that the key mapping seems random. There is a bit of oxidation visible on the back side of the mainboard, and I think that is causing stray currents that are messing up the keyboard operation.

So I think I will need to clean that off to get proper function. Any suggestions for cleaning products would be welcome.


Re: Just pulled out my C1P

Posted: Mon Jan 28, 2019 6:14 am
by keith
Having pulled the board back out and looked at it more closely, I'm not sure there is any visible corrosion after all. I recalled having seen some stains, but now that I look at it more closely, I think that is flux from the soldering. But something is messing up the keyboard mapping. Pressing 1 might get you 'q', for example.


Re: Just pulled out my C1P

Posted: Tue Jan 29, 2019 4:01 am
by Mark
According to the schematics I have, U3 & U2 are the keyboard row write select latches (74LS75) and U4 & U5 are the column read tri-state buffers (74LS125).
OSI SYN600 reads keyboard starting from row0 to row7. "Q" is on row1, "1" is row7.

If the chips are socketed, you could try swapping U4 & U5 (74LS125) and U2 & U3 (74LS75) to see if the problem moves.
If you give more examples of keypress & response it may be possible to figure out the logic error.
Make sure the diodes for the keyboard are OK, and the latch outputs on U2, U3 are cycling at D/C/W/M?

Code: Select all

      7    6    5    4    3    2    1    0 (Read bits, column read)
  7- 1/!  2/"  3/#  4/$  5/%  6/&  7/'

  6- 8/(  9/)  0/@  :/*  -/=  rub

  5- ./>   L    O    lf   cr

  4-  W    E    R    T    Y    U    I

  3-  S    D    F    G    H    J    K

  2-  X    C    V    B    N    M   ,/<

  1-  Q    A    Z   spc   //?  ;/+   P

  0- rpt  ctl  esc            lsh  rsh  caps
  ^(Write Bits, row sel) 

 (Bits Inverted on C1 0=selected/pressed)

My keyboard just failed with intermittent no response from certain rows. Turned out my keyboard column buffers were horribly oxidized (black) in the sockets. Cleaning them solved my problem.


Re: Just pulled out my C1P

Posted: Thu Jan 31, 2019 10:34 pm
by keith
I did pull, clean, and reset the four chips involved in keyboard decoding, and as you suggested might be the case, one of them had some black corrosion, which I cleaned with an eraser.

The current behavior is that the key mapping seems to work correctly as long as I hold the Left Shift key down. Without it, the keys map strangely. The Right Shift appears to operate correctly.

However, the machine is basically working. I was able run short BASIC programs (which were a pain to enter due to the keyboard issue).

Unfortunately, the capacitor between the two 75125 chips is cracked. I'm not certain if it was already that way, or if I did that getting the chips out.

So on the one hand, I'm pretty pleased that the C1P that has been sitting on a shelf for 35 years seems largely operational. On the other hand, the keyboard issue is currently making it rather difficult to use.


Re: Just pulled out my C1P

Posted: Fri Feb 01, 2019 1:48 am
by keith
Oh, good gosh, I'm an idiot. After cleaning the keyboard decoding chips, the only problem was that the Shift Lock key was jammed. Once I fixed that, the C1P appears to work just fine.



Re: Just pulled out my C1P

Posted: Sun May 05, 2019 2:50 pm
by Jeff

Haha. Reading through your post made me chuckle. I kept thinking “shift lock, shift lock.”


Re: Just pulled out my C1P

Posted: Sat May 18, 2019 8:45 pm
by keith
Yes, I got a laugh out of it too, after the fact.

My C1P is still working perfectly, btw. Although that one capacitor has a crack in the shell, it doesn't seem to be affecting its operation. Even if it did, it would be simple fix to replace it.

Everything is working just fine, which is pretty incredible given that it spent more than 30 years on a shelf in my garage. All I really had to do, is clean the thing a bit.