Error 9 causes

Post Reply
lowrybt1
Posts: 98
Joined: Sun Mar 08, 2015 3:42 pm

Error 9 causes

Post by lowrybt1 » Sun May 20, 2018 9:23 pm

Looking for some diagnostic help. One of my MPI B51 drives has started throwing off an Error 9 whenever I try to read/write to a track. As far as I can tell (trying to listen carefully), the head is not seeking/tracking. I suppose this could be due to failure of some component on the logic board (will try to swap in a spare) or the tracking motor. I’m also wondering if it could be a PSU issue. Not supplying right voltage and/or current.

Thoughts?
C4PDF w. 24K, 2 x 5.25 MPI B-51 drives
C1P RevB with fully-populated 610 board and A-13. Klyball D-13.
Spares: 600 Rev.D, 610 board, 540A, A-13 with homebuilt data separator, MPI B-51 logic board (w/o data sep module) and mechanicals

dave
Site Admin
Posts: 451
Joined: Tue Sep 09, 2008 5:24 am

Re: Error 9 causes

Post by dave » Mon May 21, 2018 3:23 am

From the ref card, Error 9 means the OS can't load the track header within one track revolution. Some questions to clarify the problem:

2) Does the problem only affect one drive, or both? If only one, can you boot from the offending drive?
3) Does this happen on every track, or some of them?
3) On a given track with the error 9 problem, does the read or write sometimes work, or always gives the error?
4) Do any disks boot to OS65D / BASIC?

lowrybt1
Posts: 98
Joined: Sun Mar 08, 2015 3:42 pm

Re: Error 9 causes

Post by lowrybt1 » Tue May 22, 2018 11:00 pm

As always, thanks Dave.

The problem affects only one drive and I can’t boot from the offending drive
Happens with every track
Always an error on R/W attempt
Disks boot on two known working drives.

Tom
C4PDF w. 24K, 2 x 5.25 MPI B-51 drives
C1P RevB with fully-populated 610 board and A-13. Klyball D-13.
Spares: 600 Rev.D, 610 board, 540A, A-13 with homebuilt data separator, MPI B-51 logic board (w/o data sep module) and mechanicals

Post Reply