Sunday with my SuperBoard II

MK14HAK
Posts: 353
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: Sunday with my SuperBoard II

Post by MK14HAK » Tue Mar 10, 2015 7:32 am

I have in mind to make a 48pin bus version of the Ram/Rom board for my 502 board Superkit. Bill I believe is happy to share his DipTrace files so its possible to do one using 48pin connector or use a cable connection from the 40pin skt. (The 600 bd 40pin expansion is NOT 505 bd 40 compatible !!)
Mike
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:HexDOS,FDD Emulator

MK14HAK
Posts: 353
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: Sunday with my SuperBoard II

Post by MK14HAK » Fri Mar 27, 2015 12:37 am

Looking forward to progress with these. Great work Bill.
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:HexDOS,FDD Emulator

BillO
Posts: 141
Joined: Tue Jul 08, 2014 4:03 pm
Location: Canada
Contact:

Re: Sunday with my SuperBoard II

Post by BillO » Fri Mar 27, 2015 2:37 pm

I'm midway through my vacation right now. Back home, but preparing for the 2nd half down in Utah. Going to be photographer for my son who is doing a series of articles and videos on motorcycle free-riding. Should be fun. I get back to this the week of the 22nd of April.
Box stock Superboard II Rev. B
KLyball replica 600D, replica 610 & KLyball Data Separator
OMS SBME and SBME+ memory cards
KLyball memory card

Jeff
Posts: 334
Joined: Fri Mar 07, 2014 4:44 am
Location: British Columbia, Canada

Re: Sunday with my SuperBoard II

Post by Jeff » Sat Apr 11, 2015 7:50 pm

I just picked up another C1P, so put me down for 2 of the memory only boards, please.
/Jeff
Image

BillO
Posts: 141
Joined: Tue Jul 08, 2014 4:03 pm
Location: Canada
Contact:

Re: Sunday with my SuperBoard II

Post by BillO » Sat Apr 25, 2015 11:04 pm

Update in Post 1.
Box stock Superboard II Rev. B
KLyball replica 600D, replica 610 & KLyball Data Separator
OMS SBME and SBME+ memory cards
KLyball memory card

Jeff
Posts: 334
Joined: Fri Mar 07, 2014 4:44 am
Location: British Columbia, Canada

Re: Sunday with my SuperBoard II

Post by Jeff » Sun Apr 26, 2015 12:56 am

I'm wondering if one of your 8T28's has gone flakey. Are you using 8T28's on both boards?

/Jeff
Image

Klyball
Posts: 195
Joined: Tue Dec 09, 2014 12:53 am

Re: Sunday with my SuperBoard II

Post by Klyball » Sun Apr 26, 2015 1:55 am

Update: 2015/04/25
Okay, back from both my trips, but I have some troubling news. For some very strange and odd reason, I am having random errors on the expansion card. This is driving me nuts as the basic design is taken from the expansion module I created about a million years ago. The only change is using the PLD for glue, which should make things even better as it's faster than the gates and 74LS138 I used before. I mean, this is butt simple!!! Next step is to scope the 5V bus for noise. Even if I see nothing, I'll use more 0.1uF caps and remove the ferrite bead on the supply line (even though it worked in the stone age!). Any and all suggestions welcome!
Hi Bill
I bread boarded up your design and used it as the sole memory for my 510 board with no problems and also had it plugged in to J2 of my 610 board addressing memory before and after the 610 memory, although I do not have a separate dd line as on your second design, the design seems solid

Grant
Replica 600 Rev D:8K,CEGMON
Replica 610 Rev B: 24k,MPI B-51 with Custom Data separator D-13
510 on the bench/replica 582 backplane/replica 470a /replica 555/original 570B/2 x Shugart 851
Ongoing : 630 ,620 ,510,542c,custom 590,SA1200,592,594,596,598

BillO
Posts: 141
Joined: Tue Jul 08, 2014 4:03 pm
Location: Canada
Contact:

Re: Sunday with my SuperBoard II

Post by BillO » Sun Apr 26, 2015 1:24 pm

Jeff wrote:I'm wondering if one of your 8T28's has gone flakey. Are you using 8T28's on both boards?

/Jeff
Tried different 8T28s and without. Same issue.
Box stock Superboard II Rev. B
KLyball replica 600D, replica 610 & KLyball Data Separator
OMS SBME and SBME+ memory cards
KLyball memory card

BillO
Posts: 141
Joined: Tue Jul 08, 2014 4:03 pm
Location: Canada
Contact:

Re: Sunday with my SuperBoard II

Post by BillO » Sun Apr 26, 2015 1:28 pm

Klyball wrote: Hi Bill
I bread boarded up your design and used it as the sole memory for my 510 board with no problems and also had it plugged in to J2 of my 610 board addressing memory before and after the 610 memory, although I do not have a separate dd line as on your second design, the design seems solid

Grant
Okay. Thanks for verifying Grant. So it must be a bad connection somewhere or a noise problem. That's where I'll look.

BTW, where did you source the 40-pin IDC type DIP plugs to connect your replica 600 & 610 boards?
Box stock Superboard II Rev. B
KLyball replica 600D, replica 610 & KLyball Data Separator
OMS SBME and SBME+ memory cards
KLyball memory card

Jeff
Posts: 334
Joined: Fri Mar 07, 2014 4:44 am
Location: British Columbia, Canada

Re: Sunday with my SuperBoard II

Post by Jeff » Sun Apr 26, 2015 2:39 pm

I asked Grant the same question. He provided this link.

http://www.digikey.ca/product-detail/en ... S-4006G-ND

/Jeff
Image

Post Reply