Sunday with my SuperBoard II

Post Reply
BillO
Posts: 141
Joined: Tue Jul 08, 2014 4:03 pm
Location: Canada
Contact:

Re: Sunday with my SuperBoard II

Post by BillO » Mon May 04, 2015 4:21 pm

Update in post 1.
Box stock Superboard II Rev. B
KLyball replica 600D, replica 610 & KLyball Data Separator
OMS SBME and SBME+ memory cards
KLyball memory card

Jeff
Posts: 331
Joined: Fri Mar 07, 2014 4:44 am
Location: British Columbia, Canada

Re: Sunday with my SuperBoard II

Post by Jeff » Mon May 04, 2015 8:50 pm

Hi Bill,

I have been reviewing your design along with the schematics of the 610 and 600 board and have been wondering about the DD line. To my (limited) understanding, the DD line is generated on whatever expansion board is plugged in and controls the data direction of the 8T28's on the 600 board. What I don't see in your design is how or where the DD signal is generated. Does it come from the lattice chip? I looked at the PLD code you posted and it doesn't seem to be in there. Could you clarify, please?

Best Regards
/Jeff
Image

Jeff
Posts: 331
Joined: Fri Mar 07, 2014 4:44 am
Location: British Columbia, Canada

Re: Sunday with my SuperBoard II

Post by Jeff » Mon May 04, 2015 9:07 pm

Hi Bill,

Please forgive me if this is a stupid question. In your first post you posted this picture:
Screen Shot 2015-05-04 at 2.01.37 PM.jpg
Screen Shot 2015-05-04 at 2.01.37 PM.jpg (188.41 KiB) Viewed 13560 times
The 8T28s (U6 and U7) on your Superboard that are used to buffer the data bus are not populated. How did it ever work without these inserted? Did you take the photo before you added those chips?

Again, please forgive the stupid question.
/Jeff
Image

BillO
Posts: 141
Joined: Tue Jul 08, 2014 4:03 pm
Location: Canada
Contact:

Re: Sunday with my SuperBoard II

Post by BillO » Mon May 04, 2015 9:21 pm

No questions are stupid Jeff, just some answers.

I hope to avoid that...

Actually, that picture was taken just between having jumpers connecting the boards data lines to the CPU's directly and putting the 8T28s in.

Since then I have tried it both ways and both ways produce exactly the same error pattern.

As to the DD line, on that original rendition of the prototype board it was just connected to the /OE line. However, as I may have mentioned, that did not allow for OR-tying. I have since added a 2N7000 to pull the DD line low. The code has changed somewhat too as I added the ability to move the 32K chip's address to begin at 0000. However, none of that has made any difference to the errors I'm seeing. I'll try to update all the files tomorrow.
Box stock Superboard II Rev. B
KLyball replica 600D, replica 610 & KLyball Data Separator
OMS SBME and SBME+ memory cards
KLyball memory card

BillO
Posts: 141
Joined: Tue Jul 08, 2014 4:03 pm
Location: Canada
Contact:

Re: Sunday with my SuperBoard II

Post by BillO » Tue May 05, 2015 5:33 pm

Code has been updated to most recent.
Box stock Superboard II Rev. B
KLyball replica 600D, replica 610 & KLyball Data Separator
OMS SBME and SBME+ memory cards
KLyball memory card

BillO
Posts: 141
Joined: Tue Jul 08, 2014 4:03 pm
Location: Canada
Contact:

Re: Sunday with my SuperBoard II

Post by BillO » Wed Jun 24, 2015 5:29 pm

Update in post 1.
Box stock Superboard II Rev. B
KLyball replica 600D, replica 610 & KLyball Data Separator
OMS SBME and SBME+ memory cards
KLyball memory card

BillO
Posts: 141
Joined: Tue Jul 08, 2014 4:03 pm
Location: Canada
Contact:

Re: Sunday with my SuperBoard II

Post by BillO » Thu Jul 16, 2015 7:31 pm

The boards are in and the RAM only board is ready to go!

See the update in post 1 for further details.
Box stock Superboard II Rev. B
KLyball replica 600D, replica 610 & KLyball Data Separator
OMS SBME and SBME+ memory cards
KLyball memory card

Steve Gray
Posts: 283
Joined: Mon Oct 06, 2008 1:54 pm
Location: Markham, Ontario, Canada
Contact:

Re: Sunday with my SuperBoard II

Post by Steve Gray » Fri Jul 17, 2015 12:14 am

Looks great! I just ordered two 32k boards!

Steve
C4P working, C1P working. 600D Replica working, C4P+D&N floppy not working. 505 board, 610 board, Mittendorf board, TOSIE hacker board need testing, PicoDOS disk untested.

MK14HAK
Posts: 351
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: Sunday with my SuperBoard II

Post by MK14HAK » Sat Jul 18, 2015 2:10 am

Awesome work Bill.

Does the ROM socket allow Ram to be fitted there for 48K or can you use say 8K on board plus the 40K ?
Please, one if each for starters.

Mike
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:HexDOS,FDD Emulator

Jeff
Posts: 331
Joined: Fri Mar 07, 2014 4:44 am
Location: British Columbia, Canada

Re: Sunday with my SuperBoard II

Post by Jeff » Sat Jul 18, 2015 2:02 pm

Bill, do you have a part number for the headers with long pins?
Image

Post Reply