Differences between OS65D V3.2 and V3.3

Post Reply
lowrybt1
Posts: 62
Joined: Sun Mar 08, 2015 3:42 pm

Differences between OS65D V3.2 and V3.3

Post by lowrybt1 » Wed Apr 12, 2017 12:31 am

Hello,

Can anyone clarify:
1. what the appropriate calls are for loading\executing the track zero copy utility on V3.2 and V3.3 5" disks (C4PMF)?
2. are the directory tracks/sectors the same for both V3.2 and V3.3 (5" C4PMF)?

Thanks. T
C4PDF w. 24K, 2 x 5.25 MPI B-51 drives
C1P RevB with fully-populated 610 board and A-13. Klyball D-13.
Spares: 600 Rev.D, 610 board, 540A, A-13 with homebuilt data separator, MPI B-51 logic board (w/o data sep module) and mechanicals

Andis
Posts: 2
Joined: Sat May 13, 2017 8:15 pm

Re: Differences between OS65D V3.2 and V3.3

Post by Andis » Sat May 13, 2017 10:49 pm

Hi,

For calling TRACK0 on my OSD65 Ver3.2, after EXITing to DOS (A* prompt), I have written a note in my User Manual that it should be :
"CA 0200=13,1 then "GO 0200".
The reason I say "should be" is that my C4PMF hangs when i try to "GO 0200". I believe that my TRACK0 file, on Track 13, is corrupted on both my regular boot disk and my Backup boot disk (I just unpacked the computer a week ago after 35 years of storage and it took me a few days to get it back up and running, so I have little memory of what shape the disks are in. Also,in trying to copy files between disks i have noticed a lot of tracks are un-writable, even after an INIT). Or it could possibly be Track 1, Sector 2 which I believe contains the routine that is run when you perform the above command.

As for the Tracks and Sectors being the same between the 2 versions, I ran the WinOSI 6502 Emulator, loading a Ver 3.3 IMG and then running the RUN"SECDIR" on the Emulator and the same on my C4PMF running Ver 3.2, and the Tracks/Sectors do not appear to be the same, though that statement can't be construed as definitive :-). I have some screen shots of both the sets of outputs if you're interested.

*** IF SOMEONE HAS OR CAN POINT ME TO THE SOURCE CODE FOR THE TRACK0 ROUTINE (Ver 3.2), IT WOULD BE GREATLY APPRECIATED ***
I'd like to see if the TRACK0 program is corrupted, or maybe, based on some reading, track 1 - sector 2 is corrupted.

Thanks
C4P-MF, 540 RevB-1, 527 w/12K, 527-RevA w/24K, 505-RevB

MK14HAK
Posts: 255
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: Differences between OS65D V3.2 and V3.3

Post by MK14HAK » Thu May 18, 2017 11:35 pm

Welcome Andis,

5"
V3.2 Copier/TK0 Util Tk13,1 (01,2 on some disks? 8" )
V3.3 Tk0 Util Tk 6,4

Call $200 (not Cegmon -reloc @ $0300)
Use WinOsi save code tools.Disassemble. osilod. ...

Good luck.
Mike
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:Archive/Restore Util,HexDOS,FDD Emulator

Andis
Posts: 2
Joined: Sat May 13, 2017 8:15 pm

Re: Differences between OS65D V3.2 and V3.3

Post by Andis » Sun May 28, 2017 3:30 am

Thanks Mike, Glad to be here. Still not sure what is causing the track0 zero issue. I did call in the COMPAR program which has a TRACK0 zero utility built into it (with a call 0200=39,1; call 2000=39,2; and then went to 'go 0200). The program came up fine, with both the compar option and the track0 write option. Everything went fine when I selected the track0 option, i.e. place original, place system, place copy. Only after I placed the copy and when the program issued the 'go 0200', it hung.

Oh well, I REALLY didn't want to get into trying to use the WinOSI and go through disassembly etc. I'm not sure I even have my serial ports hooked up (assume id do).

Anyways, I had just finished testing the audio and was shooting a screen shot of the "final product" (attached) and was DONE, and the computer just went dead (no fan, anything). I'll post for help in a few days. Just too frustrated after i had everything i wanted running smoothly. It was gorgeous on my 51 in Plasma (the only thing i have that will display the video well...). I get the feeling I'm going to have to get (hopefully only) some power supply parts... I'll pull out the Volt Meter Monday....

Have a good weekend :-)
Attachments
0527171740a.jpg
0527171740a.jpg (849.13 KiB) Viewed 13 times
C4P-MF, 540 RevB-1, 527 w/12K, 527-RevA w/24K, 505-RevB

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests