WinOSI lives!

MK14HAK
Posts: 353
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: WinOSI lives!

Post by MK14HAK » Wed Nov 14, 2018 6:32 am

WinOSI bugs and wish list.

v1.5

Some versions of DOS the DI command hangs in 1.5. (maybe fixed now with recent Index issues
resolved?)

Breakpoints not clearing sometimes.


Bring back 16 byte view. ***
Would be nice to have Debugger show memory view in optional 16 or 8 byte view mode.I currently
prefer 1.3 debugger for the 16 byte view and the fact that it shows PG0 and stack in one
view.I only wish it would remember a resized window on exit as for v1.5.\
My PET peeve is that a number of file windows are not re sizeable and open full screen.

The ASCII dump that the 8 byte view allows can be seen with Exmon and it ASCII is also
searchable with Exmon so I think it may get limited use in WinOSI debugger. INMHO.

Setting a memory address then switching to stack and back does not retain the memory address.
Ouch! Nor on exiting the debugger.

Would be nice to have a HOTKEY for the config file open.***
Select config.ini from list in file menu for booting different machines.

Larger Image Content window in Disk image mount window.(Full width) Please***

File widows default to show all files.**

F9 File Open/Close toggle LED indicator on task bar.

Show DOS65 Directory
Show HexDOS Directory
14 Char directory support

I do like the Mounted disk names now showing along with the hotkeys - nice.I was going to
suggest them show on bottom task bar but they are now fine as is.Also CPU slow down is handy.

v1.7

Ability to open 5.25" and 8" images in the one configuration at the same time.
65C02 support ??
Cut/Paste support for Cegmon ?
Support 4K ROM at $F000 remapping ACIA
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:HexDOS,FDD Emulator

MK14HAK
Posts: 353
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: WinOSI lives!

Post by MK14HAK » Tue Jan 22, 2019 8:56 am

Mark, with some versions of OS65D DOS the DI command hangs in versions 1.5. Have you any idea why or a fix in your next update. I would like to run autoSI / autoDC in v1.5 using the serial ports.
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:HexDOS,FDD Emulator

MK14HAK
Posts: 353
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: WinOSI lives!

Post by MK14HAK » Sat Sep 28, 2019 11:08 pm

I would like to see image file size support for a custom DOS allowing a 99 track image ?? (5.25" would do)

I have been trying to test my autoDC-SI_65U version in WinOSI. With currently no working 8" drives, I am using WinOSI v1.6 (serial port) and sending my splits from TeraTerm using com-0-com virtual port to WinOSI running autoDC to create a disk image. The result is a sluggish data transfer and corrupt file.I have been using a port sniffer but cannot determine if the issue is with com-0-com or WinOSI serial implementation.
If I run the macro from a separate machine via a real com port to autoDC running in WinOSI the image creation is fine. It would be nice if I could use the virtual port on the one machine to re create images as a feature I originally intended with autoDC. Any ideas why this may be failing ???
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:HexDOS,FDD Emulator

Mark
Posts: 58
Joined: Tue Sep 16, 2008 6:04 am
Contact:

Re: WinOSI lives!

Post by Mark » Sun Sep 29, 2019 6:30 am

I'm happy to send out a beta of the current build of WinOSI to any members willing to test it & report back.

There have definitely been a lot of changes since 1.6. - I better put it together since I opened my mouth. :-) I think you'll be pleasantly surprised.

-Mark

Post Reply