560Z Build thread

Klyball
Posts: 154
Joined: Tue Dec 09, 2014 12:53 am

560Z Build thread

Post by Klyball » Sun Feb 05, 2017 8:44 pm

***UPDATE*** bin loader is needed to properly load pdp8 paper tape images boot file is updated to load binary images

I thought i would start a thread on building the 560z ,as the boards look like they are soon to be done.

I have worked on the driver software, and by reading the documents it was written for 65d ver2 and up but it looks like they dropped support with ver3.
I have modified the code to work with ver 3, the only part that is not working is the Bin loader , but unless your using paper tape its not needed . if we can find a ver2 image or write a bit of code we could get it working. I have attached a .LOD file
BOOTZB.zip
with a working 65d for serial (it should work on video) and the driver package, start it at $2217 then GO 3800. you could strip out the driver at $3200,$3400 and $3800.

Things to note : make sure IRQ and NMI are pulled high on the system side of the buss.

Looking forward to seeing your results

Cheers
Grant (KLyBAll)
You do not have the required permissions to view the files attached to this post.
Replica 600 Rev D:8K,CEGMON
Replica 610 Rev B: 24k,MPI B-51 with Custom Data separator D-13
510 on the bench/replica 582 backplane/replica 470a /replica 555/original 570B/2 x Shugart 851
Ongoing : 630 ,620 ,510,542c,custom 590,SA1200,592,594,596,598

glitch
Posts: 94
Joined: Mon Nov 28, 2011 12:43 am

Re: 560Z Build thread

Post by glitch » Thu Feb 16, 2017 1:09 am

So I started building one of these up tonight...does this thing go in a Challenger II/III style chassis backwards -- with the components facing the rear panel of the system? I can't see how else it would go, unless I'm totally misreading the manual and the SYS bus goes to the Challenger backplane?
Check out The Glitch Works
OSI Challenger 3, 510 CPU, 8" floppies, 74 MB hard disk system in need of restore
Parts bin Challenger 3 board set, never had a chassis in its time

Klyball
Posts: 154
Joined: Tue Dec 09, 2014 12:53 am

Re: 560Z Build thread

Post by Klyball » Thu Feb 16, 2017 3:38 am

Hi Glitch, you are correct it goes in backwards compared to other osi boards, i think the idea is to put it in the front so a 4 slot back plane can hang off it
Replica 600 Rev D:8K,CEGMON
Replica 610 Rev B: 24k,MPI B-51 with Custom Data separator D-13
510 on the bench/replica 582 backplane/replica 470a /replica 555/original 570B/2 x Shugart 851
Ongoing : 630 ,620 ,510,542c,custom 590,SA1200,592,594,596,598

MK14HAK
Posts: 264
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: 560Z Build thread

Post by MK14HAK » Thu Feb 16, 2017 3:51 am

Yes definitely. Well spotted. Hope I remember when I get to plug one in ! Kind of weird having B1 on the right hand side of the bus and boards is confusing enuff.
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:Archive/Restore Util,HexDOS,FDD Emulator

glitch
Posts: 94
Joined: Mon Nov 28, 2011 12:43 am

Re: 560Z Build thread

Post by glitch » Thu Feb 16, 2017 12:51 pm

Oh good, for a minute I thought I had several hundred dollars of worthless boards due to some sort of screw-up :)
Check out The Glitch Works
OSI Challenger 3, 510 CPU, 8" floppies, 74 MB hard disk system in need of restore
Parts bin Challenger 3 board set, never had a chassis in its time

glitch
Posts: 94
Joined: Mon Nov 28, 2011 12:43 am

Re: 560Z Build thread

Post by glitch » Fri Feb 17, 2017 3:34 pm

Well it looks like 8T95s are going to be easy this time -- one of my suppliers has 1800 of them in stock! I've just purchased all of them, so if anyone needs them for other projects let me know. They're 74LS365s which are direct interchange.
Check out The Glitch Works
OSI Challenger 3, 510 CPU, 8" floppies, 74 MB hard disk system in need of restore
Parts bin Challenger 3 board set, never had a chassis in its time

MK14HAK
Posts: 264
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: 560Z Build thread

Post by MK14HAK » Sat Feb 18, 2017 3:48 am

I would be interested to know what suppliers you use as a source for these older components ?? I know Dave has a list online but you probably have others ?
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:Archive/Restore Util,HexDOS,FDD Emulator

glitch
Posts: 94
Joined: Mon Nov 28, 2011 12:43 am

Re: 560Z Build thread

Post by glitch » Sun Feb 19, 2017 1:48 pm

I use a number of suppliers, a few localish (within an hour or two drive), and of course I troll eBay as well.

Just picked up 300x 8T26 bus transceivers!
Check out The Glitch Works
OSI Challenger 3, 510 CPU, 8" floppies, 74 MB hard disk system in need of restore
Parts bin Challenger 3 board set, never had a chassis in its time

Klyball
Posts: 154
Joined: Tue Dec 09, 2014 12:53 am

Re: 560Z Build thread

Post by Klyball » Tue Feb 21, 2017 1:46 am

Working 560z ,drivers tested and working with 430b for pdp or z-80 terminal
Binary loader patched to load pdp papertape images from OSI terminal side.

There is no memory mangement in the pdp iot handler so it will need to be microcoded in (i have been trying to wrap my head around it) to use more then 4k.

My master plan is to interface a heathkit h-8 front panel i have kicking around to the z-80 side

for 6100 side i wonder if this would work should only need a extra serial port and memory management microcoded in
https://github.com/drovak/os8diskserver
here is a good starting point for the IOT's
http://homepage.cs.uiowa.edu/~jones/pdp8/man/index.html
DSC_0001.JPG
DSC_0012.JPG
You do not have the required permissions to view the files attached to this post.
Replica 600 Rev D:8K,CEGMON
Replica 610 Rev B: 24k,MPI B-51 with Custom Data separator D-13
510 on the bench/replica 582 backplane/replica 470a /replica 555/original 570B/2 x Shugart 851
Ongoing : 630 ,620 ,510,542c,custom 590,SA1200,592,594,596,598

glitch
Posts: 94
Joined: Mon Nov 28, 2011 12:43 am

Re: 560Z Build thread

Post by glitch » Tue Feb 21, 2017 2:28 pm

Beautiful, great work! Are you running 5.25" or 8" disks for OS-65D?

I'm in the process of getting bench space freed up for the Challenger III chassis. Currently have a number of other projects crowding both the main debug bench and the long bench I use for burn-in/also debugging.
Check out The Glitch Works
OSI Challenger 3, 510 CPU, 8" floppies, 74 MB hard disk system in need of restore
Parts bin Challenger 3 board set, never had a chassis in its time

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests