FlashFloppy / Gotek floppy emu working with OSI disk images

nama
Posts: 299
Joined: Wed Mar 30, 2011 9:44 am
Location: New Zealand
Contact:

Re: HxC / Gotek floppy emu working with OSI disk images

Post by nama » Mon Nov 19, 2018 10:29 pm

That's great news.
So you got a second Gotek Drive, or did you get a HxC unit?
It's strange that the original Gotek did not work.

Anyway, If you end up creating .hfe disk images of anything that isn't available on Daves site, please share.

Cheers

Philip

2P (1mhz 32k) - 502 + 8k + CEGMON + garbage collector fix BASIC, D&N MEM-CM9 + 24k, 540 (mono), D13 + Gotek
4PMF (2mhz 24k) - 505, 540, 527, D13 + 5.25" + Gotek
Superboard RevD - CEGMON
Spares - 2 x 527, 1 x 527 [600, 610, D13 boards]

lowrybt1
Posts: 135
Joined: Sun Mar 08, 2015 3:42 pm

Re: HxC / Gotek floppy emu working with OSI disk images

Post by lowrybt1 » Tue Nov 20, 2018 1:47 am

I’d been trying to use the HxC -- but the C4P would freeze and the HFE images would become corrupted. I ordered a Gotek and it works great.
C4PDF w. 24K, 2 x 5.25 MPI B-51 drives
C1P RevB with fully-populated 610 board and A-13. Klyball D-13.
Spares: 600 Rev.D, 610 board, 540A, A-13 with homebuilt data separator, MPI B-51 logic board (w/o data sep module) and mechanicals

nama
Posts: 299
Joined: Wed Mar 30, 2011 9:44 am
Location: New Zealand
Contact:

Re: HxC / Gotek floppy emu working with OSI disk images

Post by nama » Tue Nov 20, 2018 4:21 am

Ok...the other way around from what I thought.
When you initially said HxC, I always thought you meant a HxC flashed Gotek.
Good stuff.

P.S. please make a fresh .hfe image of your Tutorial disk 5. Thanks

2P (1mhz 32k) - 502 + 8k + CEGMON + garbage collector fix BASIC, D&N MEM-CM9 + 24k, 540 (mono), D13 + Gotek
4PMF (2mhz 24k) - 505, 540, 527, D13 + 5.25" + Gotek
Superboard RevD - CEGMON
Spares - 2 x 527, 1 x 527 [600, 610, D13 boards]

tanteju
Posts: 12
Joined: Mon Dec 24, 2018 12:28 am

Re: HxC / Gotek floppy emu working with OSI disk images

Post by tanteju » Wed Jan 09, 2019 10:39 am

Hello,

In my effort to get an old EC65 (Octopus 65/Samson 65) working again, which used back then OS65D as well, I noticed that my remaining disks are only partly readable. The system used the same floppy controller technology, just on different addresses (E0xx instead of C0xx).

Therefore I've installed a Gotek and Philip sent me OS65D HFE files wich could be read by the computer. As I need to make changes (and not completely sure about them so far), I tried to change data in memory and run the OS65 Kernel, which works mostly fine. But writing the data then back to the disk does not work. The written tracks become unreadable (wrong format).

If I change the data on some other system and use OSIHFE, I could read most of the tracks (some fail), but what could I do to have R/W access on that system?

BTW: If anyone has a copy of the OS65D disk "Loys", which is the patched version for this type of computer, getting the data would be greatly appreciated.

Mark
Posts: 55
Joined: Tue Sep 16, 2008 6:04 am
Contact:

Re: Flash Floppy / Gotek floppy emu working with OSI disk images

Post by Mark » Thu Jan 10, 2019 2:26 am

Hi,
What firmware are you using on the Gotek?
I have used flashfloppy with Gotek to initialize and copy disks on the OSI with good success.

Is there a schematic and or memory map of the EC65 available? Do you have a copy of the EC65 ROM data? If so, perhaps the WinOSI emulator could be coaxed to emulate some new configurations?

Cheers,

-Mark
Last edited by Mark on Thu Sep 19, 2019 4:56 am, edited 1 time in total.

tanteju
Posts: 12
Joined: Mon Dec 24, 2018 12:28 am

Re: HxC / Gotek floppy emu working with OSI disk images

Post by tanteju » Thu Jan 10, 2019 2:29 pm

Mark wrote:
Thu Jan 10, 2019 2:26 am
What firmware are you using on the Gotek?
I have used flashfloppy with Gotek to initialize and copy disks on the OSI with good success.

Is there a schematic and or memory map of the EC65 available? Do you have a copy of the EC65 ROM data? If so, perhaps the WinOSI emulator could be coaxed to emulate some new configurations?
Hi,

The Gotek is using the latest HxC firmware. In fact I received it two weeks ago.

Schematics are fully available. Hans Otten collected documentation. See for all schematics: http://retro.hansotten.nl/uploads/eljun ... rcomp1.pdf

This is the memory map:
Image

ROM Image is available as well, the forum just does not allow me to attach it, so here is a link to (hopefully) the same image: https://www.emuparadise.me/M.A.M.E._-_M ... -65/179448

As I do not use Windows, WinOSI is no option for me :(


The effects are:
Using created disks (HFE files) for reading does work.
Creating my own disk with OSIHFE works as well and the disk is readable
Initialising a track (e.g. IN 13) seems to work. A DI 13 shows an empty track afterwards. But putting any data on that track, e.g. SA 13,1=8000/8, does never come back. Reset and going into kernel again does show a corrupt track.
If I do the same with a real floppy disk, it works. Which indicates to me, that my adjustments to FDC addresses are so far correct.
Attachments
Bildschirmfoto 2019-01-10 um 15.09.50.png
Bildschirmfoto 2019-01-10 um 15.09.50.png (82.93 KiB) Viewed 2235 times

Mark
Posts: 55
Joined: Tue Sep 16, 2008 6:04 am
Contact:

Re: HxC / Gotek floppy emu working with OSI disk images

Post by Mark » Thu Jan 10, 2019 10:10 pm

Thanks for the EC65 info!

With my FlashFloppy programmed Gotek, I booted OS65D on a C4PMF, and ran the similar instructions, saving D000/8, later loading with EX D000=13 on WinOSI to copy it here. The FlashFloppy programmed Gotek had no issues.
CWXv

The system is now open for modification.

Ok
EXIT
A* IN 13

A*DI 13

TRACK 13
A*SA 13,1=D000/8

A*DI 13

TRACK 13
01-08
A*SA 13,1=D000/8
So my suggestion would be to reflash Gotek with FlashFloppy firmware until we discover what is making HxC unhappy. That will get you running at least. Good Luck!
-Mark

dave
Site Admin
Posts: 561
Joined: Tue Sep 09, 2008 5:24 am

Re: HxC / Gotek floppy emu working with OSI disk images

Post by dave » Tue Jan 15, 2019 3:49 am

tanteju wrote:
Thu Jan 10, 2019 2:29 pm
[ROM Image is available as well, the forum just does not allow me to attach it, so here is a link to (hopefully) the same image:
@tanteju: Thanks for the links!

For some reason (perhaps legal reasons?) Emuparadise makes it very hard to download the ROM images. I found a workaround and was able to down load the ROMs, attached here.

PhpBB seems to be hard to control sometimes. We had some issues with attachments--especially images--in the past. To add the attachment, you should be able to click the "Attachments" tab which should be visible below the text window when posting. I have given myself the same privileges as a regular user (not an admin) when making this post, and it seems to work. Can anyone else confirm that posting is not working for them?

Dave
Attachments
ec65.zip
(4.19 KiB) Downloaded 122 times

tanteju
Posts: 12
Joined: Mon Dec 24, 2018 12:28 am

Re: HxC / Gotek floppy emu working with OSI disk images

Post by tanteju » Thu Jan 17, 2019 10:22 pm

Mark wrote:
Thu Jan 10, 2019 10:10 pm
Thanks for the EC65 info!

With my FlashFloppy programmed Gotek, I booted OS65D on a C4PMF, and ran the similar instructions, saving D000/8, later loading with EX D000=13 on WinOSI to copy it here. The FlashFloppy programmed Gotek had no issues.

So my suggestion would be to reflash Gotek with FlashFloppy firmware until we discover what is making HxC unhappy. That will get you running at least. Good Luck!
Thanks for the wishes, but no luck. The Gotek with HxC boot loader does not recognise the FlashFloppy.UPD, so I could not change the software on the drive without starting to replace the boot loader.

I wonder, why my generated HFE files have 1,4 MB, while the ones Phillip sent me, all have 1,1 MB (not that it would work better on those)?

lowrybt1
Posts: 135
Joined: Sun Mar 08, 2015 3:42 pm

Re: HxC / Gotek floppy emu working with OSI disk images

Post by lowrybt1 » Sun Jan 20, 2019 6:03 pm

From lots of trial and error, I can confirm that floppy emulating devices flashed only with HxC simply will not work with OSI and/or 65D. I tested multiple different devices produced by Lotek and the Gotek. Saw the same thing you are seeing: corrupting of tracks/images and in fact corruption of the HxC flashrom. My only, very uniformed, speculation is that there is a subtle timing/voltage issue.

Goteks updated with Flashfloppy work great. I can’t explain why but I can say that this conclusion comes after much testing of various hardware/firmware combinations. Get a Gotek preloaded with Flashfloppy and use the image/shell provided by Phil (I think it’s Phil).

By the way, I also encountered the discrepancy between image sizes created with straight-up HFE versus OSIHFE. Again, there must be some subtle settings encoded in OSIHFE that result in stable images. The 1.4MB images created with HFE’s standard software never worked with OSI/65D beyond the first few R/W’s.

Tom
C4PDF w. 24K, 2 x 5.25 MPI B-51 drives
C1P RevB with fully-populated 610 board and A-13. Klyball D-13.
Spares: 600 Rev.D, 610 board, 540A, A-13 with homebuilt data separator, MPI B-51 logic board (w/o data sep module) and mechanicals

Post Reply