600D Colour RAM. Help!!!! SOLVED!

waltermixxx
Posts: 118
Joined: Sun Feb 03, 2019 10:31 pm

Re: 600D Colour RAM. Help!!!!

Post by waltermixxx » Tue May 21, 2019 2:28 pm

so I replaced the U79 74LS86 exclusive or gate with a spare 74LS04 inverter. ( I pulled out pin 15 of U74 and connected it to the output of the inverter I used to replace the ls86 gate) this was done to reduce propagation delay the ls86 might have introduced. The result was unfortunately the same, still data not getting written correctly to the 4 bit 1K ram chip. :(
next replace U20 and U21 or test in my 866 mini pro (it tests ttl chips) :)

Are there any REV D 600's out there? Bill? Jeff? DAVE? have you guys had a chance to test your 4 bit 1k ram out? :)

Cheers. :)
Turning into quite an OSI Junkie (HTFDTH?) Superboard II REV B-40K, 9600b, HC-05 Bluetooth, Superboard II Rev D, C4P rebuild- 502, 542c, 540B. :)

Jeff
Posts: 331
Joined: Fri Mar 07, 2014 4:44 am
Location: British Columbia, Canada

Re: 600D Colour RAM. Help!!!!

Post by Jeff » Wed May 22, 2019 5:50 am

I haven’t built mine yet.

/Jeff
Image

waltermixxx
Posts: 118
Joined: Sun Feb 03, 2019 10:31 pm

Re: 600D Colour RAM. Help!!!!

Post by waltermixxx » Wed May 22, 2019 6:18 pm

okie doke. thanks for replying. :)
we are so close (by we I mean Steve) to finishing up the
colour board. So figuring out the ram issue would make the colour board,
all the more worth while. :)
Turning into quite an OSI Junkie (HTFDTH?) Superboard II REV B-40K, 9600b, HC-05 Bluetooth, Superboard II Rev D, C4P rebuild- 502, 542c, 540B. :)

dave
Site Admin
Posts: 561
Joined: Tue Sep 09, 2008 5:24 am

Re: 600D Colour RAM. Help!!!!

Post by dave » Thu May 23, 2019 7:15 am

I wish I could help, but I haven't built mine either.

waltermixxx
Posts: 118
Joined: Sun Feb 03, 2019 10:31 pm

Re: 600D Colour RAM. Help!!!!

Post by waltermixxx » Thu May 23, 2019 3:41 pm

Thank you for replying :)

I'm confident that when Josh builds his, (and I have been coaxing him to start...) we will find a solution,
as he is a master of this kind of stuff... :)

In the mean time, random colours are still kinda cool? :)
Turning into quite an OSI Junkie (HTFDTH?) Superboard II REV B-40K, 9600b, HC-05 Bluetooth, Superboard II Rev D, C4P rebuild- 502, 542c, 540B. :)

Steve Gray
Posts: 283
Joined: Mon Oct 06, 2008 1:54 pm
Location: Markham, Ontario, Canada
Contact:

Re: 600D Colour RAM. Help!!!!

Post by Steve Gray » Sat Jun 01, 2019 1:21 am

Here's the 99% complete 600D Color board (16-color simplified)...
600D Colour Min.jpg
600D Colour Min.jpg (127.86 KiB) Viewed 1502 times
The first person to solve the color ram writing issue gets a free blank pcb when complete (pending verification that it AND the fix are working together ;-) ).

I'm just tweaking the board routing and labels and will verify fit of the mounting hole and then I'll do a small run (~10) of board.

Steve
C4P working, C1P working. 600D Replica working, C4P+D&N floppy not working. 505 board, 610 board, Mittendorf board, TOSIE hacker board need testing, PicoDOS disk untested.

Klyball
Posts: 195
Joined: Tue Dec 09, 2014 12:53 am

Re: 600D Colour RAM. Help!!!!

Post by Klyball » Thu Jun 06, 2019 11:46 pm

Is this color board based on the 630 color section?

looking at the schematic it looks like you need to cut a trace on the 600d pin pin 10,11 are tied together on j75 these need to be separate when plugging into the color board. cut blue trace
video.JPG
video.JPG (194.28 KiB) Viewed 1443 times
Replica 600 Rev D:8K,CEGMON
Replica 610 Rev B: 24k,MPI B-51 with Custom Data separator D-13
510 on the bench/replica 582 backplane/replica 470a /replica 555/original 570B/2 x Shugart 851
Ongoing : 630 ,620 ,510,542c,custom 590,SA1200,592,594,596,598

Steve Gray
Posts: 283
Joined: Mon Oct 06, 2008 1:54 pm
Location: Markham, Ontario, Canada
Contact:

Re: 600D Colour RAM. Help!!!!

Post by Steve Gray » Fri Jun 07, 2019 12:31 am

Yes, they are tied together, however this is designed to allow the 630 board to invert the video signal using BIT0 from colour ram (the "invert" line) and output to composite video. This does not affect reading or writing, and I also do not use this on my colour board.

Were there any modifications made to the board other than adapting for EPROM and keyboard switches?

Steve
C4P working, C1P working. 600D Replica working, C4P+D&N floppy not working. 505 board, 610 board, Mittendorf board, TOSIE hacker board need testing, PicoDOS disk untested.

Klyball
Posts: 195
Joined: Tue Dec 09, 2014 12:53 am

Re: 600D Colour RAM. Help!!!!

Post by Klyball » Fri Jun 07, 2019 3:50 am

No other changes made other than the roms

I ll check the board to schematic again but all seems to be correct to schematic
Replica 600 Rev D:8K,CEGMON
Replica 610 Rev B: 24k,MPI B-51 with Custom Data separator D-13
510 on the bench/replica 582 backplane/replica 470a /replica 555/original 570B/2 x Shugart 851
Ongoing : 630 ,620 ,510,542c,custom 590,SA1200,592,594,596,598

Steve Gray
Posts: 283
Joined: Mon Oct 06, 2008 1:54 pm
Location: Markham, Ontario, Canada
Contact:

Re: 600D Colour RAM. Help!!!!

Post by Steve Gray » Sun Jun 09, 2019 3:05 pm

Good news! The colour writing issue has been solved! Walter, Josh and Myself got together with a logic analyzer and a schematic printout and put our heads together to solve it.... Well, it was mostly Josh as we figured it would be ;-) On page 4 of the schematic is an unlabelled jumper at the top right near U56. The jumper defaults to A10. To fix the issue this has to be changed to +5V. We tested and writing is solid.

So, Josh and Walter will both get a free Colour Board! Thanks guys!

Steve
Last edited by Steve Gray on Mon Jun 10, 2019 4:30 am, edited 2 times in total.
C4P working, C1P working. 600D Replica working, C4P+D&N floppy not working. 505 board, 610 board, Mittendorf board, TOSIE hacker board need testing, PicoDOS disk untested.

Post Reply